Nous détaillons l'installation de PDT le plugin eclipse soutenu par Zend.

Eclipse est désormais disponible en version 3.4 (Ganymede), malheureusement cette version est incompatible avec PDT. Si toutefois vous souhaitez plus d'informations : Installez PDT v2.0.0 et Eclipse 3.4

Pour installer PDT sur un eclipse "vierge", il faut :

  • Aller dans le menu d'eclipse dans Help > Software Updates > Find and install...
  • Choisir "search for new features to install"
  • Ajouter un "New Remote Site..."
Name : PHP Development Tools
URL : http://download.eclipse.org/tools/pdt/updates/
  • Cocher aussi "Europa Discovery Site"
  • Sélectionner dans : "PHP Development Tools" > "PDT features" > "PDT Feature 1.0.xxxxxxx"
  • Un message d'erreur doit apparaitre :
PDT Feature (1.0.2.v20080102-79-7GE7QYGHNGPGY) requires feature "org.eclipse.wst (2.0.0)", or compatible.
  • Il suffit de sélectionner "Europa Discovery Site" et de cliquer sur le bouton "Select Required"
  • Et voila, il suffit de finir le processus d'installation, redémarrer Eclipse (pour ouvrir la perspective PHP : il suffit d'aller dans le menu : Window > Open perspective > Other... :)