Si vous essayez de l'installer, vous risquez d'obtenir les messages d'erreurs suivant :

Cannot complete the request.  See the details.
Unsatisfied dependency: org.eclipse.php_feature.feature.group 1.0.2.v20080102-79-7GE7QYGHNGPGY requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.feature.group/[2.0.0,3.0.0)
Unsatisfied dependency: org.eclipse.php_feature.feature.group 1.0.2.v20080102-79-7GE7QYGHNGPGY requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.feature.group/[2.0.0,3.0.0)

Pour l'instant, il est donc recommandé de rester en version 3.3 (eclipse Europa) avec PDT 1.0.3

Si toutefois vous souhaitez tester la version 2.0.0 de PDT (en cours de développement) avec eclipse 3.4, vous trouverez une explication d'installation ici : http://wiki.eclipse.org/PDT/Installation#Eclipse_3.4_.2F_Ganymede_.2F_PDT_2.0

Pour info, la release 2.0 est prévue pour le 15 septembre 2008 (http://www.eclipse.org/pdt/).